1<?xml version="1.0" encoding="UTF-8"?>
2<!--
3  ~ Copyright (c) 2017 Cisco and/or its affiliates.
4  ~
5  ~ Licensed under the Apache License, Version 2.0 (the "License");
6  ~ you may not use this file except in compliance with the License.
7  ~ You may obtain a copy of the License at:
8  ~
9  ~     http://www.apache.org/licenses/LICENSE-2.0
10  ~
11  ~ Unless required by applicable law or agreed to in writing, software
12  ~ distributed under the License is distributed on an "AS IS" BASIS,
13  ~ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
14  ~ See the License for the specific language governing permissions and
15  ~ limitations under the License.
16  -->
17
18<project xmlns="http://maven.apache.org/POM/4.0.0"
19         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
20         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
21    <modelVersion>4.0.0</modelVersion>
22
23    <groupId>io.fd.honeycomb.scripts</groupId>
24    <artifactId>scripts-parent</artifactId>
25    <version>1.19.08-SNAPSHOT</version>
26    <packaging>pom</packaging>
27    <name>${project.artifactId}</name>
28
29    <properties>
30        <!-- groovy -->
31        <maven.groovy.version>1.6.2</maven.groovy.version>
32        <groovy.version>2.5.5</groovy.version>
33        <groovy.eclipse.compiler.version>3.3.0-01</groovy.eclipse.compiler.version>
34        <groovy.eclipse.batch.version>2.5.6-02</groovy.eclipse.batch.version>
35        <odl.yang-binding.version>0.13.2</odl.yang-binding.version>
36    </properties>
37
38    <dependencyManagement>
39        <dependencies>
40            <dependency>
41                <groupId>org.codehaus.groovy</groupId>
42                <artifactId>groovy-all</artifactId>
43                <version>${groovy.version}</version>
44                <type>pom</type>
45            </dependency>
46            <dependency>
47                <groupId>org.codehaus.groovy</groupId>
48                <artifactId>groovy-templates</artifactId>
49                <version>${groovy.version}</version>
50            </dependency>
51            <dependency>
52                <groupId>org.opendaylight.mdsal</groupId>
53                <artifactId>yang-binding</artifactId>
54                <version>${odl.yang-binding.version}</version>
55            </dependency>
56        </dependencies>
57    </dependencyManagement>
58
59    <build>
60        <pluginManagement>
61            <plugins>
62                <plugin>
63                    <groupId>org.apache.maven.plugins</groupId>
64                    <artifactId>maven-site-plugin</artifactId>
65                    <configuration>
66                        <skip>true</skip>
67                        <skipDeploy>true</skipDeploy>
68                    </configuration>
69                </plugin>
70            </plugins>
71        </pluginManagement>
72        <plugins>
73            <plugin>
74                <groupId>org.codehaus.groovy</groupId>
75                <artifactId>groovy-eclipse-compiler</artifactId>
76                <version>${groovy.eclipse.compiler.version}</version>
77                <extensions>true</extensions>
78            </plugin>
79            <plugin>
80                <artifactId>maven-compiler-plugin</artifactId>
81                <version>3.8.0</version>
82                <!-- 2.8.0-01 and later require maven-compiler-plugin 3.1 or higher -->
83                <configuration>
84                    <compilerId>groovy-eclipse-compiler</compilerId>
85                    <source>1.8</source>
86                    <target>1.8</target>
87                </configuration>
88                <dependencies>
89                    <dependency>
90                        <groupId>org.codehaus.groovy</groupId>
91                        <artifactId>groovy-eclipse-compiler</artifactId>
92                        <version>${groovy.eclipse.compiler.version}</version>
93                    </dependency>
94                    <!-- for 2.8.0-01 and later you must have an explicit dependency on groovy-eclipse-batch -->
95                    <!-- https://mvnrepository.com/artifact/org.codehaus.groovy/groovy-eclipse-batch -->
96                    <dependency>
97                        <groupId>org.codehaus.groovy</groupId>
98                        <artifactId>groovy-eclipse-batch</artifactId>
99                        <version>${groovy.eclipse.batch.version}</version>
100                    </dependency>
101                    <dependency>
102                        <groupId>org.codehaus.groovy</groupId>
103                        <artifactId>groovy-all</artifactId>
104                        <version>${groovy.version}</version>
105                        <type>pom</type>
106                    </dependency>
107                </dependencies>
108            </plugin>
109        </plugins>
110    </build>
111</project>