pom.xml revision 2ea62795
1<?xml version="1.0" encoding="UTF-8"?>
2<project xmlns="http://maven.apache.org/POM/4.0.0"
3         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
4         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
5
6    <!-- have to basically duplicate common-scripts, it cannot be used as parent because of jar packaging -->
7
8    <properties>
9        <!-- groovy -->
10        <maven.groovy.version>2.0</maven.groovy.version>
11        <groovy.version>2.4.7</groovy.version>
12        <groovy.eclipse.compiler.version>2.9.2-01</groovy.eclipse.compiler.version>
13        <groovy.eclipse.batch.version>2.4.3-01</groovy.eclipse.batch.version>
14    </properties>
15
16    <modelVersion>4.0.0</modelVersion>
17    <groupId>io.fd.honeycomb.it</groupId>
18    <artifactId>benchmark-scripts</artifactId>
19    <version>1.18.07-SNAPSHOT</version>
20    <packaging>jar</packaging>
21
22    <build>
23        <pluginManagement>
24            <plugins>
25                <plugin>
26                    <groupId>org.apache.maven.plugins</groupId>
27                    <artifactId>maven-site-plugin</artifactId>
28                    <configuration>
29                        <skip>true</skip>
30                        <skipDeploy>true</skipDeploy>
31                    </configuration>
32                </plugin>
33            </plugins>
34        </pluginManagement>
35        <plugins>
36            <plugin>
37                <groupId>org.codehaus.groovy</groupId>
38                <artifactId>groovy-eclipse-compiler</artifactId>
39                <version>${groovy.eclipse.compiler.version}</version>
40                <extensions>true</extensions>
41            </plugin>
42            <plugin>
43                <artifactId>maven-compiler-plugin</artifactId>
44                <!-- 2.8.0-01 and later require maven-compiler-plugin 3.1 or higher -->
45                <configuration>
46                    <compilerId>groovy-eclipse-compiler</compilerId>
47                </configuration>
48                <dependencies>
49                    <dependency>
50                        <groupId>org.codehaus.groovy</groupId>
51                        <artifactId>groovy-eclipse-compiler</artifactId>
52                        <version>${groovy.eclipse.compiler.version}</version>
53                    </dependency>
54                    <!-- for 2.8.0-01 and later you must have an explicit dependency on groovy-eclipse-batch -->
55                    <dependency>
56                        <groupId>org.codehaus.groovy</groupId>
57                        <artifactId>groovy-eclipse-batch</artifactId>
58                        <version>${groovy.eclipse.batch.version}</version>
59                    </dependency>
60                </dependencies>
61            </plugin>
62        </plugins>
63    </build>
64
65    <dependencies>
66        <dependency>
67            <groupId>org.codehaus.groovy</groupId>
68            <artifactId>groovy-all</artifactId>
69            <version>${groovy.version}</version>
70        </dependency>
71    </dependencies>
72</project>